Zerene Stacker

FAQ: Frequently Asked Questions

Purchasing

File Formats

Shooting Stacks

Stacking

Retouching

Miscellaneous

What are the differences between Personal, Prosumer, and Professional?

There are two classes of differences:
1. how you are permitted to use the product, and
2. what technical features are provided.

Very briefly, Professional Edition is required for uses beyond personal satisfaction and educational instruction. If you're selling images or using the software as part of your job or to support a business, museum, or funded project, then you need Professional Edition. Professional Edition also provides access to the software's most advanced technical features and extended access to our support staff.

Prosumer Edition is our flagship product for non-professional users. It includes all the technical features from Professional Edition, but at a reduced price for advanced consumers.

Here is a full list of the features that require Prosumer Edition or Professional Edition. (We call these features “Pro-only” for short.)

  • Lightroom plugin
  • Option to honor image files' embedded color profiles in Zerene Stacker's own screen displays.
  • Ability to overlap I/O with computation for faster operation while stacking.
  • Ability to reduce the frequency of screen updates while stacking, for faster operation with deep stacks.
  • Additional brush types for retouching.
  • Multi-step undo when retouching.
  • Additional interpolators for improved handling of very sharp source images.
  • Integrated controller for the StackShot automated rail
  • Ability to ingest and stack images while they are being shot with a USB-connected camera.
  • When retouching, image brightness can be adjusted to facilitate working in unusually dark regions.
  • Aligned and brightness-corrected input images can be saved to external files.
  • Pixels from each source image that were incorporated into DMap output can be saved as image files.
  • Depth map from DMap can be saved as a TIFF file.

Personal Edition is our entry-level product. It contains all the features that you're likely to need for most applications, plus free trials of the Pro-only features. Trials of Pro-only features cover a 30-day period that starts when each feature is first used. To continue using a Pro-only feature after its trial period has expired, you can upgrade to Prosumer Edition by contacting support@zerenesystems.com .

I see some menu items labeled (Pro). What does that mean?

Menu items are labeled (Pro) if you need a Professional Edition or Prosumer Edition license to use them beyond a 30-day trial. Each of these “Pro-only” features has a separate trial period that begins when that feature is used for the first time. After first use, you can keep using the feature for another 30 calendar days. If you don't have a Professional or Prosumer license when the trial period expires, the feature becomes disabled and appears gray in the menu. If you get tired of looking at those grayed-out items, go to Options > Preferences > Look & Feel, and select the option to “Hide unlicensed features after trial period has expired”.

Do I have to pay more to get 64-bit mode?

No, it's the same price. Zerene Stacker supports 64-bit mode in all editions including Student and Personal.

I'm upgrading my computer. Do I have to buy a new license?

No, your same license still works, even if you're going from 32-bits to 64-bits.

I have both a Mac and a PC. Do I need two licenses?

No, you can mix-and-match however you like, as long as you stay within the total number of computers allowed by the license.

Can I purchase the software on CD?

The software is only available by download, but it's easy to make your own CD. Each download is just a single file that is also suitable for offline installation. Just use any machine that is connected to the Internet to download the version you need. Burn it to CD or thumbdrive on that machine, then carry the CD or thumbdrive to your offline machine and install the software there. Your license key can be transferred the same way. Just write the email to a text file, burn that to CD or thumbdrive, move it to the offline machine, and install the key.

I bought a license, how do I install it?

Licenses get installed using copy/paste at Options > Registration while Zerene Stacker is running. Just be sure to include the whole license key including all the equal signs ==== and everything between them. For detailed instructions, see HERE. If you're currently running an expired trial, then pay particular attention to step 5 because a browser window may be covering up part of Zerene Stacker that you need to install the license.

Will Zerene Stacker work with my camera?

Yes. Zerene Stacker will work with any camera. That's because it does not attempt to talk directly with your camera. It just processes the image files that the camera creates. You can tether your camera to a computer so that Zerene Stacker can immediately access the captured images, but in that case it will be some other piece of software that's talking with the camera. Our Tutorials section includes discussion of several commonly used software packages for tethering.

What kinds of image files will Zerene Stacker handle?

The input and output formats are JPEG and TIFF, the latter in either 8- or 16-bit RGB. In general the most reliable TIFF format is uncompressed; some compressed formats such as 16-bit ZIP are not readable. A few other formats such as PNG and BMP can be read but not written.

Does Zerene Stacker handle raw files?

To process raw files takes two separate steps. First you convert the raw files to some RGB format, typically TIFF, and then you stack the TIFF files.

For highest quality, we recommend converting raw files to 16-bit TIFF using your favorite raw converter and whatever settings make it work the best. After stacking the 16-bit TIFFs, tell Zerene Stacker to save its output also as 16-bit TIFF.

Because 16-bit TIFF files are not compressed and also have deeper pixels than any current raw format, this process retains all of the image quality intrinsic to the raw formats.

Zerene Systems does not provide raw converters. You can download those separately, or use software provided by your camera manufacturer.

If you use Lightroom, then be aware that there's a Lightroom plugin for Zerene Stacker that handles raw conversion automatically. When using Lightroom with the plugin, processing raw files is just a matter of selecting them and doing an Export to Zerene Stacker. See Working with Lightroom for more details.

How does Zerene Stacker handle color profiles?

By default, whatever color profile is used by the input files is also copied through to output files that are saved as JPEG or TIFF. However, color profile is ignored in Zerene Stacker's own screen displays unless the option is set to “Use input file profiles for ZS screen displays” (at Options > Preferences > Color Management). This advanced Pro-only feature is set off by default in the trial version. As a result, stacks using a wide-gamut profile such as ProPhotoRGB may appear significantly different when displayed by Zerene Stacker than when displayed by Photoshop or similar tool. On some computers Zerene Stacker will also ignore the color profile of your monitor, so that even sRGB images look different than shown in Photoshop. These differences may be worrisome if you don't know what's causing them, but the key thing to remember is that the color profile will be correct in the output file.

Note: there is an optional setting at Options > Preferences > Color Management that can cause color profiles to be omitted from output files. If you're having trouble with profiles, check there to be sure that the Output option is selected to “Copy profile from input”.

How do I save images as TIFF or JPEG?

You need to use File > Save Output Images(s). That will give you a choice of TIFF or JPEG, with options appropriate for each format (compression quality for JPEG, 8- versus 16-bit for TIFF).

It's a common mistake to use File > Save Project and then notice that what gets saved are .zsj and .zsy files that can't be used by anything besides Zerene Stacker. File > Save Project is for tasks like coming back tomorrow to retouch an image that you generated today. It stores images in lossless formats and keeps track of alignment information so that you can resume work immediately, with no expensive computation. See Saving Work In A "Project" for more discussion about that.

Why do my output images say they're only 72 dpi?

First, be reassured that your output images have the same number of pixels as your input images. You haven't lost anything and all your original lovely detail is still there. The output images themselves don't actually say 72 dpi. What's happening is that Zerene Stacker has produced an output image that doesn't have a dpi specification at all, and whatever tool you're using to look at the image has assigned its own default interpretation of “72 dpi”. Dpi is not meaningful for screen images, and for prints dpi is implied by the combination of print size and pixel count. If you really do need some particular setting for dpi inside the image file because that's how a requirement happens to be specified, then just pull the file into Photoshop, do an Image > Image Size… with the checkmark removed on “Resample Image”, then save the result to a new file.

Does Zerene Stacker help me to shoot a stack?

In most cases, no. Typically you'll shoot a stack either by controlling focus manually, or by using a camera control device such as CamRanger, or by tethering your camera and using a program like ControlMyNikon or ControlMyCanon. In all those cases, Zerene Stacker does not participate in the capture process. The only time that Zerene Stacker gets involved in controlling the shooting of a stack is when you're using a StackShot rail and you've chosen to use Zerene Stacker's own Stackshot control panel for that.

Does Zerene Stacker correct for changes in magnification as I focus?

Yes, it surely does. This question is often asked by people who are worried about focusing by using the big ring on their macro lens. In that case it's clear that magnification changes along with focus. But it turns out that there are magnification changes almost all the time due to perspective, no matter how you focus. The software doesn't care what the cause is for magnification changes; it just corrects for all of them.

Does it matter if I shoot the stack in order?

For DMap, it's definitely best if the frames are processed in order, either front-to-back or back-to-front. If they're out of order, then the result may still look OK at first glance but it's almost certainly degraded. Often there will be obvious artifacts like nasty halos.

PMax itself does not care about order, but going from one end straight to the other is still the safe way to get good alignment. Sometimes when source frames are processed out of order, enough error accumulates in the alignment process that two frames focused at nearly the same depth but far apart in the stack order end up aligned slightly differently. When that happens, you get artifacts like “echoes”.

Does it matter if I work front-to-back or back-to-front?

Front-to-back versus back-to-front makes no difference in most cases. The visibility methods currently used by Zerene Stacker are symmetric with respect to depth order. They produce the same image quality and artifacts no matter which way the stack is processed. The default behavior is to start processing at the narrow end of the stack, meaning whichever end appears to have a smaller FOV based on comparing first and last frames. That choice reduces or eliminates edge streaking and in some cases can slightly improve the quality of alignment. Options are provided to process the stack in a specific order if desired, but those are to control framing, not image quality.

One exception occurs if your subject is liable to move away while you're shooting. In that case you should start at whichever end you consider most important, so that if the subject does leave you may still have something useful to work with.

Do I need a focus rail?

If you're shooting very small subjects such as details of insects and flowers, then a high precision screw-driven focus rail is very helpful and sometimes required.

However, you don't need a focus rail for many applications, and in fact for larger subjects you'll probably get better results by stepping focus with the ring on your lens. See HERE for more discussion on that point.

Lenses with auto-focus capability can usually be controlled very precisely by software if you tether your camera to a computer. See the Tutorials Index for suggestions regarding software to do that.

How do I figure out what aperture setting and step size to use?

There are several good ways to figure out what aperture setting and step size to use.

If you're going to be shooting a lot of stacks under similar conditions, then one very good method has four major steps:

  1. Decide what magnification you want to shoot at. Even with the same lens, the best aperture setting will be different at 1:1 than it is for a landscape.
  2. At the selected magnification, shoot a series of pictures that vary the aperture setting over its entire range. Look closely at the pictures and find the one that has the most depth of field while still retaining the sharpness you need, in the plane of best focus. Whatever aperture setting took that picture, that's the one you want.
  3. At the selected magnification and aperture setting, experiment with different step sizes to find the largest step size that gives a clean result with no focus banding.
  4. Write down what you found, and use your notes to guide further work under similar circumstances.

The above procedure is very reliable and automatically incorporates your own criteria and the requirements of your own application. Both of those can make large differences in determining which aperture setting and step size are best for what you're doing. However, this experimental method obviously takes a fair amount of effort.

As a shortcut, you can skip steps 3 and 4, and rely instead on the tables that we've provided HERE. They basically rely on computation to determine for you a step size that will prevent focus banding, once you have determined the magnification and aperture setting that you want to work at. Similar tables that provide focus distances for landscape and other large scale work can be found HERE.

By the way, it turns out that the classic tables and formulas for DOF are not so good for focus stacking with modern cameras and display software. They worked OK for shooting single pictures with film and prints, but now the numbers that they produce are often too large. If you rely on the old values, you're very likely to see focus banding when you zoom in to look at “actual pixels” and full camera resolution.

How much memory should I allocate to Zerene Stacker?

The memory requirement is determined by image size as measured by pixel count. The ideal setting is roughly 100 MB for each 1 megapixel, so 12 megapixel images need 1200 MB, 24 megapixel images need 2400 MB, and so on. Somewhat smaller settings can be used, down to a minimum of roughly 75 MB for each 1 megapixel, but this may make stacking run a little slower.

Note that the memory requirement depends on pixel count and not on input file size or number of frames in the stack. There is no significant difference in memory requirement between processing JPEG and TIFF images, and the memory requirement does not increase with deeper stacks.

In most cases it is counterproductive to allocate much more memory than described above, because this will just cause more contention with other processes in your computer.

What is the best way to add files?

Drag-and-drop is usually the quickest and easiest method. You don't have to use Add Files at all. Just open another window showing your operating system's file chooser, either Windows Explorer or Macintosh Finder. Select files there, then press and hold the mouse button while dragging the selected files onto the Input Files panel of Zerene Stacker. Release the mouse button to drop the files into Zerene Stacker. This method is more powerful and flexible than Add Files because you can use all the display options provided by your operating system, including tables of thumbnails or popping up another image viewer if you need to take a closer look at some image before deciding to add it to Zerene Stacker.

My output image has a band of streaks on one side. Why is that?

Streaked edges happen when some source images are centered differently from others. The streaks appear in areas that are outside the frame of at least one image.

What happens is that the software picks one frame, either the first or last, to use as a master. Then each succeeding frame essentially gets registered against the first using a rotate/shift/scale approach based on comparing the image content. If it happens that a later frame ends up not covering the whole area covered by the first frame, then the software fills in the missing edge strips with copies of the closest available pixel. As a result, any detail that appears along the edge of the frame gets smeared from wherever registration puts it clear out to the edge of the frame. That produces streaks like the ones you see. Sometimes the streaks do not propagate clear through to the output because they are overwhelmed by stronger real detail in other frames. But when the filled-in streaks are the strongest available “detail”, then they propagate to the output and produce the effect you see.

Streaked edges are common for stacks that are shot handheld. They can also happen with a focus rail if the camera is pointed a little bit to the left or right, or tipped up or down, or if the rail is mounted on a tripod that sags when the camera is moved. Shooting through some stereo microscopes can also produce this effect, because with those scopes the camera is essentially shooting what one eye sees, and that's pointed a little bit left or right to produce the stereo effect.

For some hints about how to investigate what's going on, see How can I detect movement in my stack?

My colors changed a little. Why is that?

There are three reasons that output images can have different colors from the input: 1) brightness adjustment, 2) PMax, and 3) “Retain full dynamic range” when saving. “Brightness adjustment” refers to Zerene Stacker's attempt to correct for uneven exposure between various input images. That feature is turned on by default, but you can turn it off by un-checking Brightness at Options > Preferences > Alignment. “PMax” refers to the PMax stacking method, which often makes slight changes in brightness, contrast, and saturation as a side effect of doing its focus stacking. This behavior is an unavoidable side effect of PMax and should be considered as one of the tradeoffs of PMax versus DMap. “Retain full dynamic” when saving causes the range of internal pixel values to be compressed if necessary to fit within the 0-255 range of image files. Internally the range can exceed 0-255 as a result of PMax, brightness adjustment, or even just pixel interpolation during alignment.

Color/brightness/contrast changes can be completely avoided by using the DMap stacking method, with Brightness adjustment turned off at Options > Preferences > Alignment, and “Retain full dynamic range” turned off at Options > Preferences > Image Saving or in the file save dialog.

How should I set the Alignment options?

The best settings at Options > Preferences > Alignment depend on what you're doing.

The default settings are to correct for every common issue:

  • scale changes due to perspective and focusing;
  • X- and Y-shifts due to handholding, or due to jitter or misalignment of a focus rail;
  • rotation due to handholding; and
  • brightness changes typically due to flash variation.

However, in many cases one or more of those issues is ruled out by hardware when the stack is shot. If you're using a focus rail or a microscope, then it's unlikely that there's any rotation to deal with. If you're using continuous illumination instead of flash, then it's probably quite consistent from frame to frame. In some microscopy work, none of these issues are important.

The basic guideline is to turn off any alignment option that you don't need. That will make the alignment process go faster. In some cases, particularly at high magnification such as through a microscope, turning off unnecessary options will also give a better result image. This issue is discussed in a lot more detail in the forum thread at http://www.photomacrography.net/forum/viewtopic.php?p=79878#79878.

What do the percentages mean for Alignment parameters?

The percentages at Options > Preferences > Alignment are limits and are measured with respect to the master frame. Most of the time they can be left at the default values, which are fairly large. Once in a while, typically with handheld work, it's necessary to increase the limits to allow correct alignment. Rarely, it's also necessary to reduce the limits to keep the software from wandering off and latching onto some bogus alignment. Typically this happens only if the image contains some strong repeating pattern like a regular grid.

What is the difference between PMax and DMap?

PMax is a “pyramid” method. It is very good at finding and preserving detail even in low contrast or slightly blurred areas. It's also very good at handling overlapping structures like mats of hair and crisscrossing bristles, nicely avoiding the loss-of-detail halos typical of other stacking programs. But PMax tends to increase noise and contrast, it can alter colors somewhat, and it's liable to produce fuzzy “inversion halos” around strongly contrasting objects.

DMap is a “depth map” method. It does a better job keeping the original smoothness and colors, but it's not as good at finding and preserving detail.

The two methods complement each other. Some types of subjects look good when they are processed automatically by PMax, but not by DMap. Other subjects are just the opposite. For particularly challenging subjects like bugs and flowers shot through microscope objectives, neither method is ideal by itself. In that case the best results are obtained by using human judgment and the retouching tool to combine the best aspects of both algorithms.

For further discussion of these issues, see “DMap versus PMax” on the Zerene Stacker: How To Use It page.

How should I choose those DMap Settings?

First, note that there's a tutorial specifically on “How To Use DMap”. Visit the Tutorials index page to find that.

But as a quick guideline, the best values for the “radius” parameters at Options > Preferences > DMap Settings depend on two things:

  1. how sharp your images are,
  2. whether there's any side-to-side movement of the subject after alignment is done.

There are basically three cases:

  • If there's no movement and your images are sharp when viewed at 100% scale (actual pixels), then set Estimation Radius = 5.
  • If there's no movement but your images are blurred when viewed at 100% scale, then reduce the scale until the image does look sharp, and set Estimation Radius to 5 increased in proportion to the scale factor. For example if your images look sharp at 50% (that is, reduced by 2X), then set Estimation Radius = 10 (because 5 times 2 is 10). Similarly if your images look sharp only at 33% (reduced by 3X), then set Estimation Radius = 15 (because 5*3=15); at 25% (4X), set ER = 20; at 20% (5X), set ER = 25; and so on. (Math geeks: compute ER=5/scale, where scale=0.25 for 25% and so on.)
  • If your stack has subject movement, then try setting Estimation Radius to between 1/100 and 1/200 of your image width in pixels, for example around 20-40 if your images are 4K pixels wide.

In any case, set Smoothing Radius to half the value of Estimation Radius.

When DMap pauses for you to Set Contrast Selection, move the slider until out-of-focus background goes black in the preview image, while your subject retains most of its natural colors. What you're doing is using your human judgment to mark “can't tell” regions where you want the program to emphasize smoothness rather than getting misled by pixel noise that might look like detail but isn't.

Note: If DMap does not pause for you to Set Contrast Selection, then go to Options > Preferences > DMap settings and remove the checkmark on “Use preset contrast threshold”. The software is distributed with that option not checked, but sometimes it gets checked by accident and then the lack of pause can be very confusing!

Should I sharpen before or after running Zerene Stacker?

In many cases it doesn't matter. If you have a “smart” sharpening tool that can identify and sharpen real detail while leaving pixel noise largely unchanged, then you may get better results by running it before Zerene Stacker. That's because it improves the “signal-to-noise ratio”, which helps Zerene Stacker to make better decisions. But with sharpening filters that do not have that level of discrimination, you'll get similar results either way and it's quicker and safer to just sharpen the final result. If you do sharpen before stacking, be sure not to oversharpen because fixing that problem would require reprocessing the whole stack.

How can I detect movement in my stack?

The easiest way is to “play” the stack as it were a filmstrip. To do this, just press-and-drag within the list of input files. File selection will track the cursor, while the image shown in the source window will update to match. This makes it easy to quickly find any portion of the stack that you are interested in, and at the same time makes it easy to joggle between two or three frames to identify the exact frame where some problem turns up.

If you have already processed the stack, then you can also put a checkmark on “Show as adjusted” in the input files panel. This will show the source images as they ended up after alignment. This makes it much easier to spot movement of the subject. Of course if you are interested in seeing how stable and well aligned your setup is, you will want to leave “show as adjusted” unchecked so that you're seeing the source images before alignment.

By default, processing the stack also generates a set of highly compressed preview-quality images that can be played more quickly than the original high quality source images. For this reason, it's usually better to put off “playing” your stack until after it's been processed once, unless you have some reason up front to suspect that subject movement may be an issue.

Why did the software reverse the order of my images?

Normally Zerene Stacker starts processing at whichever end of the stack has the narrower field of view. This is to minimize or prevent edge streaking, which otherwise may appear in edge regions that are not covered by some source image. The narrow end of the stack can be either foreground or background, depending on exactly what lens you're using and how you're doing the focus stepping. The software determines which end is narrower by comparing images in the first and last frames. Sometimes in microscopy the decision looks essentially random because it depends on the arrangement of objects in the image and how they appear to change size as they go into and out of focus.

You can stop Zerene from automatically setting the order by going to Options > Preferences > Alignment and removing the checkmark on “Automatic order”. Then you can switch the order, if desired, by using File > “Reverse order”.

Can I directly control the order that images are processed?

Sure. First, go to Options > Preferences > Alignment and remove the checkmark on “Automatic order”. This will prevent Zerene Stacker from rearranging the stack based on its analysis of which end has a narrower field of view.

If you need to set the order very precisely, then you may also have to add the images one at a time or in small groups, using drag-and-drop or Add File(s) multiple times. Each time you drop files into the Input Files panel or click the Add button inside the Add File(s) dialog, ZS will sort the newly added files by name.

By removing the checkmark on “Automatic order” and adding files one at a time, you can set exactly any order that you want.

Why do my saved output images look washed out?

Probably you accidentally put a checkmark on “Retain full dynamic range” while saving the image. Remove that checkmark at Options > Preferences > Image Saving, or when you save your next image, and the problem will go away.

What does "Retain full dynamic range" mean?

As background, you need to know that the PMax stacking method often causes contrast to increase, pushing darks darker and brights brighter. If your source images are already high contrast, then the increase can internally push pixel values to “darker than black” or “brighter than white”. Such values cannot be saved in ordinary image files. By default, Zerene Stacker clips these pixels to exactly black or white when the file is saved, thus throwing away some information you might like to keep. Placing a checkmark on “Retain full dynamic range” essentially does a “levels adjustment” that reduces contrast and possibly brightens the image, exactly enough to occupy the full range of allowed pixel values, 0-255 in an 8-bit image. This preserves all the computed pixel values so that you can apply your own levels or curves adjustment in Photoshop or any similar tool to get whatever appearance you like best. When using “Retain full dynamic range”, it's also a good idea to use 16-bit TIFF output, so as to preserve good gradation that might be lost if the extra dynamic range were compressed into 8 bits.

What is the PMax setting "Retain UDR Image"?

UDR stands for Unrestricted Dynamic Range. As discussed in the previous FAQ, the PMax stacking method often causes contrast to increase, pushing darks darker and brights brighter. To compensate for this effect, the last step of the PMax method is a type of HDR (High Dynamic Range) local adjustment of contrast & brightness that preserves detail in overly light regions while pushing those regions back into standard bounds. By selecting the option to “Retain UDR Image”, you can preserve the image as it stood just before the HDR step. This allows you to run your own HDR methods outside Zerene Stacker, say in Photoshop. When you select “Retain UDR Image”, each run of PMax produces two Output Images, one of them with “UDR” in its name. To finish processing that image outside Zerene Stacker, you should save it as 16-bit TIFF using “Retain full dynamic range” on the save.

What are some tips for fast retouching?

We have a whole separate page about that; see Tips for Retouching.

Do you have a user forum?

There is no forum dedicated to just Zerene Stacker. Instead, for most users we recommend going to photomacrography.net, a strictly non-commercial web forum that covers all aspects of the photography of small things. Many of our users and the principal developer of Zerene Stacker are active participants there, and we prefer to keep our efforts concentrated in one place. Photomacrography.net has a well-earned reputation for in-depth technical information, combined with astounding images created by world-class photographers who are happy to discuss tips, techniques, and tools from all sources. On the other hand, if you're working entirely with subjects that too large to discuss at photomacrography.net, then the best source of information is to email support@zerenesystems.com. We'll be happy to either answer your questions ourselves or point you to other resources as appropriate.

How does Zerene Stacker work with Lightroom?

We have a separate document for that: see Working With Lightroom.

Are there any keyboard shortcuts?

There are several keyboard and mouse shortcuts for selecting images and for adjusting image scale and brush size. Those are described HERE.

Currently there are no keyboard shortcuts for common operations such as opening and saving files.

Is there some way to turn off the welcome screen?

On Macintosh no; on Windows, yes. Right-click the launch icon to open Properties and go to the Shortcut tab. Add the parameter -noSplashScreen to the end of the Target line, like this:

    "C:\Program Files\ZereneStacker\zerenstk.exe" -noSplashScreen
    

Is there some way to control those output names?

You've probably noticed that the default names are based on timestamps — good for uniqueness but not necessarily what you want for readability. You can construct your own templates to include source image numbers, processing options, and so on. This feature is documented at Options > Preferences > Image Saving; look at the Template field.

The Zerene Stacker icon -- what is it?

The “smiling dog” image is the wing pattern of a California Dogface butterfly, Zerene eurydice. See HERE for an explanation of how the name “Zerene” came to be used for the software also.

I need to report a problem. Are there log files I can send you?

Yes, a log file is automatically saved for each execution that encounters an unexpected problem. One log file is also saved for the last normal execution. All you need to do is locate these files in the ZereneStacker application directory as described below, then attach them to an email sent to support@zerenesystems.com. The logs are ordinary text files that you can look at with any text editor if you have any concerns about their content. As an alternative to attaching the file, the content can also be copy/pasted into the body of your email.

To locate log and configuration files, proceed as follows:

  • On Windows, do a Start > Run on the Windows taskbar. In the little window that pops up, specify to Open: ”%APPDATA%\ZereneStacker” (note, no space in the name). Click OK. This will open a file explorer window showing the ZereneStacker folder in your user area.

  • On Mac OS X, use Finder to navigate to your home directory, and from there to your home directory's Library/Preferences/ZereneStacker.
    Note that the required directory is not in the /Library/Preferences that hangs off the root of your computer's disk. Instead it is the one located in your own home directory, ~/Library/Preferences. In recent versions of Mac OS X (“Lion” and later), your own Library folder is normally hidden in Finder. To see into it, simply click the Go menu in Finder, then press and hold the Option (Alt) key to add Library to the list of available folders (as shown HERE). Continue holding the Option key while you click on Library to view its contents, then double-click to open the Preferences folder and then the ZereneStacker folder.

Probably the ZereneStacker folder will contain several log files. To identify the proper one, consider the circumstances: If you received a popup diagnostic that said “Uh-oh – something went wrong and caused an internal error”, then the file is named something like *ErrorLog20110508090456.txt, where the digits indicate date & time (2011 May 8 at 09:04:56 am). If you did not receive such a popup, then the log file is LastNormalLog.txt.

stacker/docs/faqlist · Last modified: 2014/09/12 02:20
Copyright 2013, Zerene Systems LLC, all rights reserved.